Maintenance on a third party site
Incident Report for KjellDEdev
Resolved
The maintenance work is now complete.
Posted Nov 12, 2020 - 19:46 CET
Identified
Due to maintenance work the website to which you are redirected at some URLs is currently unavailable.
Posted Nov 11, 2020 - 15:51 CET
This incident affected: Redirect links (kjellde.dev/go/terraconia., terra.kjellde.dev/aquastore).